Browse
Tools
Categories

SiteAudit v7.5 OnSite & Hosted .NET v4.8 Framework Requirement

Reference Number: AA-01257 Views: 531 Last Updated: 08-19-2022 05:07 PM 0 Rating/ Voters

SiteAudit v7.5 Fails to Install/Run Due to Incorrect .NET Framework Version

Microsoft .NET v4.8 Framework is a mandatory prerequisite for SiteAudit v7.5.  This affects upgrading the SiteAudit Hosted Data Collection Agents (DCA) client and the Control Panel. The SiteAudit Hosted DCA cannot be successfully upgraded until the prerequisite is met.  And SiteAudit OnSite cannot be upgraded or installed until the prerequisite is met.   

Content

  • V7.5 .NET Framework requirements
    • How to check which .NET Framework version is installed
  • What to do if .NET v4.8 Framework is not installed

V7.5 .NET Framework Requirements

Beginning with SiteAudit v7.5, Microsoft .NET Framework version is 4.8 is required to be installed on all machines where SiteAudit software runs. SiteAudit v7.5 cannot be successfully installed without this version. Please make sure this version is installed as well as any other recommended platform requirements.  

To check which version of .NET is installed on the machine:

  • Open Windows PowerShell as administrator
  • Copy the script below and paste it into PowerShell
    (Get-ItemProperty "HKLM:\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full").Release -ge 528040
  • Click the Enter key on the keyboard to execute the script
    • If the value returned is True, then the correct version of .NET Framework is installed
    • If the value returned is False, then .NET Framework v4.8 must be installed

 

  

For further answers you can reference a Netaphor support article .NET Framework https://support.netaphor.com/index.php?/article/AA-00850/0/

The article provides the steps to verify that the proper version of Microsoft .NET Framework is installed prior to installing SiteAudit components on your computer.

There are several other insights that indicate you are not running .NET v4.8 Framework.  These are listed below:

-       The Viewer closes on its own after you open it

-       The Viewer Time Span date and time does not advance. Select the Inventory view and set the Time Span to All.  The To date shows the last time data was stored 

These behaviors indicate SiteAudit was installed but it cannot connect to the database.  Therefore you need to install .NET v4.8 Framework to complete the installation.

 

What to do if .NET Framework v4.8 is not installed

The simple answer is if you are not running .NET v4.8 Framework you need to download it from the Microsoft download site and install it using the following link 
https://dotnet.microsoft.com/en-us/download/dotnet-framework/net48

The machine may need to be rebooted after installing the .NET Framework. Once this is done, the installation should be complete and SiteAudit can be opened.